← Back to team overview

kicad-developers team mailing list archive

Compiling KiCAD under MSYS


Hello everyone,

Following exactly the description in 'COMPILING.txt' I'm not able to build KiCAD by using MSYS as build environment under Windows 7 (64 bit).
The problem is that wx header files cannot be found although the appropriate directories are within the search path of the gcc.
I tried many different settings but the only solution I have found so far was to replace within the generated makefiles all occurrences of /usr/local (or whatever I have tried beside this) with the absolute Windows path to the wx installation directory.

Could someone please be so kind and provide some information about his/her MSYS build environment?

1) Where are the wxWidgets (MSW) sources located?

2) What has been passed as '--prefix=' to configure?
cmd: grep -i 'with options' config.status # could be executed in the wx build directory

3) Where have the wxWidgets binaries been installed?

4) Which mount points are existing?
cmd: mount

5) What are the search directories of gcc?
cmd: gcc -v -c foo.c 2>&1 | sed ':1;s,/[^/.][^/]*/\.\./,/,;t 1'

6) What does wx-config provide as location for headers and binaries?
cmd: wx-config --libs
cmd: wx-config --cppflags

7) Where is the wx library expected by the KiCAD build?
cmd: grep -i root_dir *.txt # could be executed in KiCAD's build directory

The reason why I would like to compile KiCAD is that I would like to continue my work on the translation resp. updating it.

Many thanks in advance.


Follow ups