← Back to team overview

kicad-developers team mailing list archive

Re: wxDialogs and tabbing order


On 03/28/2012 07:08 AM, Wayne Stambaugh wrote:
> On 3/27/2012 3:46 PM, Dick Hollenbeck wrote:
>> On 03/22/2012 12:14 AM, Dick Hollenbeck wrote:
>>> On 03/21/2012 05:40 PM, Wayne Stambaugh wrote:
>>>> On 3/21/2012 12:41 PM, Dick Hollenbeck wrote:
>>>>> There is no response to the tab key in the EESCHEMA library pin edit dialog, on Linux,
>>>>> using very latest.
>>>> I just check this out with KiCad bzr 3473 and it works on fine Debian
>>>> Testing with Gnome 3.2 and wxWidgets 2.8.12.
>>>> Wayne
>>> Haven't tried it with 2.8 yet.
>>> But said problem occurs with SVN HEAD wxWidgets, which could be spanking new un-released
>>> non-sense.
>>> Or I may have built it incorrectly.
>>> Thanks, my faith is restored.
>>> Dick
>> No, this particular dialog is broken, even using wx 2.8.10
>> This the eeschema library pin editing dialog.  No response to the TAB key.
>> I want to tab from pin name to pin number, and no go.
>> Dick
> I just confirmed this.  I'm not sure why it worked the last time I
> tested it.  Maybe I forgot to update my repo.  It appears that the panel
> that renders the pin is somehow grabbing the tab key.  The behavior in
> Windows is particularly amusing as the name text control begins adding a
> square indicating an unprintable character each time the tab key is
> pressed.  I'll take a look at it as soon as I get some time.
> Wayne

Thanks for your time Wayne.  You are an awesome co-worker man!

There is probably a few clicks in wxformbuilder that might fix this.

But who has the time?  HELP!


Follow ups