← Back to team overview

kicad-developers team mailing list archive

Re: Revised batch plot control file


On 8/7/2012 2:20 PM, Lorenzo Marcantonio wrote:
I revised my ideas on the batch plot facility after some experimentation (the testbed was useful). Here is a 'converted' control file showing all that it can do at the moment.

All the features are in there, only the parser/executor has to be implemented.

My 'biggest' problem on the dsnlexer for now was that the comment character is # instead of ; (and it choked on my lisp commenting habits:P:P)

Mailing list: https://launchpad.net/~kicad-developers
Post to     : kicad-developers@xxxxxxxxxxxxxxxxxxx
Unsubscribe : https://launchpad.net/~kicad-developers
More help   : https://help.launchpad.net/ListHelp


I have a few minor comments.

1) Please consider using underscores in multiple word tokens, "subtract_mask_from_silk" is easier to read then "subtractmaskfromsilk". This is even more important if we have to edit this file by hand.

2) (layer (layernum ##)) seems like overkill to me. For consistencies sake (layer NAME ##) is how it is defined in the kicad_pcb file. At some point in the future the layer numbers may go away or change so the layer name may be a safer to use in the long run.

3) The "stem" token is confusing. I think "suffix" would be a better choice here.

4) The "outputformat" token should be shortened to "format".

Other than that it looks really good. I am looking forward to being able to set up my plot definition file and getting all of my plots in one shot. Thanks you for your efforts.


Follow ups