← Back to team overview

kicad-developers team mailing list archive

Re: kicad footprint plugins wizard in windows

 

It may be better to make exposed pad as array of smaller pads for better application of solder paste. This will also allow to easily change the pad into array of tht pads for improved power dissipation. Below - how I did it in C (full code here: https://github.com/michal777/KiCad_Footprint_Generator). I think exposed pad should be numbered max+1 because sometimes there are more exposed pads.


if((exposed_pad_x != 0) && (exposed_pad_y != 0)) //if there is exposed pad, make subdivision
    {
exposed_pad_part_size_x = exposed_pad_x / exp_pad_subdiv_x; //size of one part of exposed pad
        exposed_pad_part_size_y = exposed_pad_y / exp_pad_subdiv_y;

exposed_pad_part_1_x = exposed_pad_part_size_x / 2 + exposed_pad_part_size_x * exp_pad_subdiv_x / 2 - exposed_pad_part_size_x; //calculate positon of first part of exposed pad exposed_pad_part_1_y = exposed_pad_part_size_y / 2 + exposed_pad_part_size_y * exp_pad_subdiv_y / 2 - exposed_pad_part_size_y;

for(ep_cnt_x = 0; ep_cnt_x < exp_pad_subdiv_x; ++ep_cnt_x) //generate exposed pad array
        {
            for(ep_cnt_y = 0; ep_cnt_y < exp_pad_subdiv_y; ++ep_cnt_y)
            {
fprintf(footprint_file, " (pad %d smd rect (at %s %s) (size %s %s) (layers F.Cu F.Paste F.Mask)\n", pad_number, f2c(exposed_pad_part_1_x - ep_cnt_x * exposed_pad_part_size_x), f2c(exposed_pad_part_1_y - ep_cnt_y * exposed_pad_part_size_y), f2c(exposed_pad_part_size_x), f2c(exposed_pad_part_size_y)); fprintf(footprint_file, " (solder_paste_margin_ratio %s))\n", f2c(exp_pad_paste_ratio));
            }
        }
    }



W dniu 29.08.2015 o 21:37, easyw pisze:
Hi,

Here is the patch vs revision 6132 for adding exposed pad to qfp_wyzard

I added the exposed pad option and changed name from QFP to QFP/QFN.
I used the function PadLineArray because I couldn't find the apis doc...
anyway it should be fine.
I assigned 0 to exposed pad pin number...
please let me know if it is fine or if I should change it to maxpin number +1.

Thank you,
Maurice

On 23/08/2015 17.29, jp charras wrote:
Le 23/08/2015 16:41, easyw a écrit :
Hi JP,

The changes are fully working.
thanks for committing.

PS
I see you added a bar code generator to fp wizard...
Do you think it would possible to add also an option for exposed pad in
qfp/qfn footprint?
thank you
Maurice

Yes, I think this is a good idea.





_______________________________________________
Mailing list: https://launchpad.net/~kicad-developers
Post to     : kicad-developers@xxxxxxxxxxxxxxxxxxx
Unsubscribe : https://launchpad.net/~kicad-developers
More help   : https://help.launchpad.net/ListHelp


Follow ups

References