← Back to team overview

kicad-developers team mailing list archive

Zone fill hangup?


I have been using Kicad 4.0.7 successfully.  I just decided to give the upcoming 5 series a try, so I set up a Fedora VM and loaded the COPR 100:r11969.dc66b73-nightlies.fc27 build.

Most everything I've tried works fine, but zone fill in pcbnew just appears to hang.  Running "top" doesn't show anything sucking up time - it just never completes.

All that I get is a dialog box titled "Fill All Zones", with a message "Calculating zone fills...".  The Elapsed time counter shows 0:00:00, and the progress bar doesn't move.  If I click the Cancel button, it goes gray, but the box stays up.

The same thing happens if I try to run a DRC - as soon as it tries to fill zones, it hangs.  This board behaves properly in 4.0.7.  I even tried deleting the zones and re-adding them but that has no effect.

I've put the project, schematic, board file, etc up on dropbox in case anyone wants to take a look at it:


I'll be happy to file a bug, but first I wanted to see if this is operator error or a known problem.


Follow ups