kicad-developers team mailing list archive
Mailing list archive
Re: [PATCH] GTK+3 zooming
Sure thing, should it also be a constructor parameter? Or construct to a default then set it?
BTW, that WX spew is now fixed upstream in the 3 branch, so a shout out to the WX people for a quick response!
On 23 November 2018 19:09:35 GMT, Seth Hillbrand <seth@xxxxxxxxxxxxx> wrote:
>Am 2018-11-23 08:26, schrieb John Beard:
>> This is a patch to refactor the zooming of WX_VIEW_CONTROL. This is
>> related to lp:1786515 , but it's not a fix, it's just a refactor
>> help debug the problem, and also tidy the code.
>This looks good. Works for me on Linux and Mac. After one of our MSW
>devs can test for ill effects there, I think we should merge these.
>The only additional change I'd like to see here would be putting the
>"500" magic number into the ACCELERATING_ZOOM_CONTROLLER's class as a
>settable value that we can later hook up to a user preferences.