← Back to team overview

kicad-developers team mailing list archive



Isn't Reece's original post the spec? In summary, the name VECTOR is confusing and the type structure could be expanded on to offer more compile time checks. He proposes a KiPoint and KiDelta, and describes their behavior clearly enough for anyone that does geometry calculations. What's missing from the spec?

On 23/06/2019 2:52 AM, Seth Hillbrand wrote:
On 2019-06-21 22:54, Reece R. Pollack wrote:
Doing this now, before we go too far down the path of replacing
wxWidgets types with non-OOB arrays would enhance readability and make
the code more robust. Using VECTOR2I is going the wrong way.

Hi Reece-

Codebase cleaning like you suggest can go a long way toward improving sustainability and readability.  But done the wrong way, it will have the opposite effect as we fight with return types that aren't fully matched.

Before we decide to do this type of deep plumbing on the KiCad innards, I'd love to see the proposed specification for what's being implemented.  Otherwise, this'll be a bike shedding discussion.


Mailing list: https://launchpad.net/~kicad-developers
Post to     : kicad-developers@xxxxxxxxxxxxxxxxxxx
Unsubscribe : https://launchpad.net/~kicad-developers
More help   : https://help.launchpad.net/ListHelp

Follow ups