kicad-developers team mailing list archive
Mailing list archive
Re: VECTOR2I and VECTOR2D
On 2019-06-21 22:54, Reece R. Pollack wrote:
Doing this now, before we go too far down the path of replacing
wxWidgets types with non-OOB arrays would enhance readability and make
the code more robust. Using VECTOR2I is going the wrong way.
Codebase cleaning like you suggest can go a long way toward improving
sustainability and readability. But done the wrong way, it will have
the opposite effect as we fight with return types that aren't fully
Before we decide to do this type of deep plumbing on the KiCad innards,
I'd love to see the proposed specification for what's being implemented.
Otherwise, this'll be a bike shedding discussion.