← Back to team overview

kicad-developers team mailing list archive

Issues with clang-format


I know this isn't a "help me program" mailing list but given the number of formatting issues which I have caused in my merge requests I figure it would be better if I could get this solved.

I am on Msys64 on Windows 10 platform

I followed the instructions herehttps://docs.kicad-pcb.org/doxygen/md_Documentation_development_coding-style-policy.htmland I get no complaints.

I don't seem to get any messages when I run git commit so I don't know if it is trying to check my formatting.

When I run the suggested line

git check-format

I get "no modified files to format" if I run it after git commit

or I get an error message

    Traceback (most recent call last): File "C:/msys64/mingw64/bin/git-clang-format", line 579, in main()         File "C:/msys64/mingw64/bin/git-clang-format", line 154, in main cd_to_toplevel()             File "C:/msys64/mingw64/bin/git-clang-format", line 336, in os.chdir(toplevel)                 FileNotFoundError: [WinError 3] The system cannot find the path specified: '/home/bjpic/brian_renum/kicad'

If I run it before git commit. I assume the "cannot find the path" error is because it is actually trying to do something but I have no idea how to fix this.

Every other aspect of git seems to work.

I have managed to fix clang-format in my IDE (I think) but obviously it would be better if git did it so I could not forget.

Thanks again.