← Back to team overview

launchpad-reviewers team mailing list archive

[Merge] lp:~abentley/launchpad/nest-part-model into lp:launchpad

 

The proposal to merge lp:~abentley/launchpad/nest-part-model into lp:launchpad has been updated.

Description changed to:

= Summary =
Support the bzr-builder nest-part instruction in the data model.

== Proposed fix ==
Update to a version of bzr-builder that supports nest-part, update the model
objects.

== Pre-implementation notes ==
None

== Implementation details ==
Extracted MAX_RECIPE_FORMAT so that it could be overridden.
Added monkey_patch to override MAX_RECIPE_FORMAT

NestInstruction.nest_path appears to have an identical purpose to
NestPartInstruction.target_subdir, and the bzr-builder's author could not
explain why they are different.  It is particularly odd since
NestPartInstruction has a nest_path that is always None.  Since both represent
the TARGET-DIR of an instruction, both are represented as
in the database as SourcePackageRecipeDataInstruction.directory.

Lint was cleaned up, though in some cases, e.g. lib/lp/testing/__init__.py, the
result was arguably not more readable.

== Tests ==
bin/test -t nest_part

== Demo and Q/A ==
None

= Launchpad lint =

Checking for conflicts and issues in changed files.

Linting changed files:
  database/sampledata/current.sql
  database/sampledata/current-dev.sql
  lib/lp/code/model/sourcepackagerecipedata.py
  database/schema/comments.sql
  lib/lp/code/model/tests/test_sourcepackagerecipe.py
  lib/lp/testing/__init__.py
  utilities/sourcedeps.conf
  database/schema/patch-2208-99-0.sql

./lib/lp/code/model/sourcepackagerecipedata.py
     189: E202 whitespace before ')'
./lib/lp/testing/__init__.py
     129: 'anonymous_logged_in' imported but unused
     129: 'with_anonymous_login' imported but unused
     129: 'is_logged_in' imported but unused
     148: 'launchpadlib_for' imported but unused
     148: 'launchpadlib_credentials_for' imported but unused
     129: 'person_logged_in' imported but unused
     148: 'oauth_access_token_for' imported but unused
     129: 'login_celebrity' imported but unused
     129: 'with_celebrity_logged_in' imported but unused
     147: 'test_tales' imported but unused
     129: 'celebrity_logged_in' imported but unused
     129: 'run_with_login' imported but unused
     129: 'with_person_logged_in' imported but unused
     129: 'login_team' imported but unused
     129: 'login_person' imported but unused
     129: 'login_as' imported but unused
     888: E302 expected 2 blank lines, found 1
     964: E302 expected 2 blank lines, found 1
./database/schema/patch-2208-99-0.sql
       4: Line exceeds 78 characters.
       5: Line exceeds 78 characters.
       6: Line exceeds 78 characters.
       7: Line exceeds 78 characters.


-- 
https://code.launchpad.net/~abentley/launchpad/nest-part-model/+merge/39560
Your team Launchpad code reviewers is requested to review the proposed merge of lp:~abentley/launchpad/nest-part-model into lp:launchpad.



References