← Back to team overview

launchpad-reviewers team mailing list archive

Re: [Merge] lp:~rvb/maas/write-dhcp-server-config into lp:maas

 

On Wednesday 01 August 2012 14:13:26 you wrote:
> === modified file 'src/provisioningserver/dhcp/config.py'
> --- src/provisioningserver/dhcp/config.py	2012-07-03 05:26:34 +0000
> +++ src/provisioningserver/dhcp/config.py	2012-08-01 14:05:22 +0000
> @@ -47,10 +47,10 @@
>      subnet {{subnet}} netmask {{subnet_mask}} {
>             next-server {{next_server}};
>             option subnet-mask {{subnet_mask}};
> -           option broadcast-address {{broadcast_address}};
> +           option broadcast-address {{broadcast_ip}};
>             option domain-name-servers {{dns_servers}};
> -           option routers {{gateway}};
> -           range dynamic-bootp {{low_range}} {{high_range}};
> +           option routers {{router_ip}};
> +           range dynamic-bootp {{ip_range_low}} {{ip_range_high}};
> 
>             pool {
>                     allow members of "uboot-highbank";
> @@ -61,6 +61,10 @@
>                     filename "{{bootloaders['i386', 'generic']}}";
>             }
>      }
> +    key maasupdate {
> +        algorithm hmac-md5;
> +        secret "{{dhcp_key}}";
> +    };


Was there a reason for not using the exact example I left in 
src/provisioningserver/omshell.py ?

This config won't work because its key name is wrong, and there's no omapi-key 
declaration.
-- 
https://code.launchpad.net/~rvb/maas/write-dhcp-server-config/+merge/117660
Your team Launchpad code reviewers is requested to review the proposed merge of lp:~rvb/maas/write-dhcp-server-config into lp:maas.


References