← Back to team overview

launchpad-users team mailing list archive

PPA buildd cache corruption



today I had some weird problems trying to use the anjuta package from
this PPA:


After installing anjuta 2: from there, I noticed
that a fix was missing which I expected to be there.  The changelog

* Drop merged upstream patchs:
    - 010_handle_patch_files_with_whitespace.patch
    - 011_fix_crash_when_adding_file.patch
    - 012_make_gbf_work_with_subdirectory_target.patch

012_make_gbf_work_with_subdirectory_target.patch was the expected fix,
but it was removed because it was merged upstream.  First, I verified
that it had indeed been merged upstream: Yep, it's there. In particular,
the original source tarball uploaded to the PPA contains the fix.  Then
I went looking for packaging errors, but found none that might cause
something like this.  Indeed, building the unchanged Debian source
package on my local machine results in different binaries, which include
the fix I wanted!

After some more investigation, I noticed that the diff listed under the
"Available diffs" heading was rather large.  Applying this incremental
diff on top of the previous Debian revision of the source package should
yield exactly the same result as applying the source package's .diff.gz
to the original source tarball, right?

Well, it doesn't.  The incremental diff is *corrupted*.

I tried copying the package to my own PPA and rebuilding it there,
without success.  I even released a new version and everything, but it
still insisted on basing the build on a corrupted buildd cache (the
build logs hint that it is indeed the cache, because the incremental
diffs are applied on top of it).  Even deletion and reuploading of a
fresh source package including the complete original tarball didn't stop
it from using the corrupted buildd cache.  Changing the upstream version
will probably fix it, but I really don't want to mess with that.


Follow ups