← Back to team overview

launchpad-users team mailing list archive

Request from Leo's owner to fix the leo-editor trunk (or trunk2) branch


Hello all,

I am Edward Ream, the owner of the Leo project. Launchpad has been great for
the Leo project, but recently we have run into problems due to a
mistaken commit of a huge file.  Deleting that file (bzr delete) has
not helped.

Recently (yesterday?) Terry Brown (tbnorth) had an exchange (given in
the Post Script) regarding this problem on #bzr irc.

The upshot seems to be that the launchpad folk need a formal request from a
Leo admin in order for bzr to fix the problem.  This is the formal
request :-)  BTW, Terry is now also an admin of the leo-editor-team.

Terry understands the details far better than I.  Please let me know
if there is anything Terry or I can do.



P.S.  Here is Terry's email to me this morning, containing the
transcript of the irc session:

That was quite surreal - unable to resolve my bzr push problem I went
to bzr IRC chat one `wgz` there is well aware of the problems with the
infamous lp:leo-editor branch, apparently from bugs posted against bzr
because of the condition it's in.

Summary - Edward as project owner you need to post on the
launchpad-users list asking them to fix it.  Here's the IRC log:

<tbnorth> hi call - can anyone explain http://pastebin.com/vmpBbKYm ?
I've been pushing to that repo. for years without trouble.  Haven't
changed ssh key or anything.
<wgz> tbnorth: they moved trunk
--> supton (~supton@ has joined #bzr
<wgz> do `bzr pull --remember lp:leo-editor`
<wgz> then move your changes onto that branch
<vila> wgz: not sure about that, did you notice the 'branchlock' part again ?
<wgz> oh, and the owner of the new branch is different too, which may
cause issues
<tbnorth> wgz might be right, the branch lp:leo-editor points to was
changed recently, although I thought I'd pushed successfully since
<wgz> this is basically all fallout from the repo that needed one
accidental giant revision removed from it
<vila> tiplog saved my day after a wrong pull --overwrite, who should
I hug again ?
<wgz> though, the way they tried to hack it is probably worse than if
I'd done what I was going to and risk breaking stacking
<tbnorth> wgz - so you know about that :)  That still doesn't seem to
be resolved though.
<wgz> tbnorth: indeed, I think this is generally a big mess that needs
sorting out properly
<wgz> I just don't have any access or ability to do anything on the
codehosting side
<tbnorth> wgz - what scope are we talking here, that one project, or a
general LP thing?
<wgz> and without someone from leo-editor saying "please fix our
branch" on launchpad-users there's not much I can do
<tbnorth> wgz - I can get the admin to ask that easily.  Didn't
realize this was a known issue :-}
<wgz> there have been some bug reports against bzr because of this
launchpad problem with the branch
<tbnorth> so when it's fixed, will existing branches still be
compatible, and will branch over http on windows not run out of
memory, which is the only issue we're having, apart from my push
<wgz> that's the goal.
<wgz> I think breaking old stacked branches is less bad than the current status.
<tbnorth> and, sorry to be so verbose, but when you say " the way they
tried to hack it is probably worse than if I'd done..." who's they?
The leo-editor team didn't do anything much except try creating a new
branch as the 'focus of development'.
<wgz> right, that move is probably the cause of your problem now
<tbnorth> my push problem, which can probably be resolved on my end,
but not the http/windows issue?
<wgz> is it now possible to branch that new line of development over
http without the memory problem?
--> supton (~supton@ has joined #bzr
<wgz> or did moving to a new branch not help?
<tbnorth> wgz - no, moving to a new branch did not help
<wgz> okay, thanks for confirming that.
<wgz> we need to fix the underlying repo.
<tbnorth> which would make sense if LP uses shared repo, I don't know
if it does or not
<wgz> it uses stacking, which is... even more funky
<tbnorth> but we can branch over http in windows from a branch not
stacked on lp:leo-editor - so if there was a way to just delete the
whole branch *completely* on lp:leo-editor and push from scratch, that
would presumably fix it
<wgz> that's close to what I think needs doing, but we need someone
from the launchpad/l-osa side to do it
<tbnorth> and having the owner of leo-editor request that in
launchpad-users would be the way to make that happen?
<wgz> yup, that would be the best first step, then I'll try and do
whatever further bothering is needed
<tbnorth> ok, thanks, I'll go and pass this on now.
<wgz> tbnorth: for your immediate problem, double check both the
branch you're pushing to is the right one of the two, and that you
have your ssh config correct for the branch
<tbnorth> ok, thanks.

Edward K. Ream email: edreamleo@xxxxxxxxx
Leo: http://webpages.charter.net/edreamleo/front.html

Follow ups