← Back to team overview

maria-developers team mailing list archive

Re: [Branch ~maria-captains/maria/5.1] Rev 2809: Support building with system libevent


Sergei Golubchik <serg@xxxxxxxxxxxx> writes:

>> Then I also need to decide what to do for packages when system
>> libevent is too old. I checked, and Debian 4+5 and Ubuntu up to 9.04
>> have only libevent 1.3. Ubuntu >= 9.10 has libevent 1.4.
>> I think the best is to use bundled libevent on those older distros. We
>> will then still suffer from
>> https://bugs.launchpad.net/maria/+bug/509521 on those, but hopefully
>> most people using plugins which require libevent will build mariadb
>> themselves and/or use a newer distro.
> What about specifying a deb dependency that mariadb needs
> libevent >= 1.4 ?
> Then package manager will handle the rest

I don't understand what you mean?

On Ubuntu 9.10 and up specifying a dependency on libevent >=1.4 will work,

But on Debian <= 5 and Ubuntu <= 9.04, a dependency on libevent >= 1.4 would
make the package uninstallable, as libevent 1.4 is not available in those
distros. Or did you mean we should provide libevent 1.4 as a package in the
OurDelta repository?

I think using system libevent on Ubuntu >= 9.10 and bundled on Ubuntu <= 9.04
and Debian should work ok. Most people installing something like the Pinba
storage engine (which uses libevent) will probably in any case recompile
mariadb. Whatever packages do will not affect them, so the important thing is
that with your patch, they can now get MariaDB to use libevent 1.4 if they
install it.

 - Kristian.