← Back to team overview

maria-developers team mailing list archive

Problem with MariaDb as a Windows service


Some person claimed here around one week ago that MariaDB would not run as
service after "mysqld --install".
I replied that it worked for me - but it does not with the latest stable
version 5.2.3 (it did with the 5.2.3 RC)
(so my apology to this person!)

Windows console output:

C:\maria52\bin>sc delete maria52
[SC] DeleteService LYKKEDES

C:\maria52\bin>mysqld --install maria52
Service successfully installed.

C:\maria52\bin>net start maria52
Tjenesten maria52 starter...
Tjenesten maria52 kunne ikke startes.

Der opstod en systemfejl.

Systemfejlen 1067 opstod.

(From Danish --> service could not start --> the system error 1067 occurred)

I have tried with both old datadir and the empty one shipped with mariaDB
and also my old my.ini as well as a fresh one.
Also I tried to add --defaults-dir to the registry (just in case I had
overlooked a my.ini copy in C:\ or C:\Windows) and adding doublequotes key
manually like
"C:\maria52\bin\mysqld" --defaults-file="C:\maria52\my.ini" maria52

I double checked there are no conflicts wit all settings.

The command
"C:\maria52\bin\mysqld" --defaults-file="C:\maria52\my.ini"
.. starts the server (also when --defaults-file is omitted) .. but not as a
service of course.

Was it tested with the 5.2.3 GA release that it will run as a Windows
The RC worked as a charm - but the GA will not. Any idea?
(I am using Win7, 64 bit, Home Premium)


Follow ups