maria-developers team mailing list archive
Mailing list archive
Re: [Commits] Rev 3991: MDEV-5138 Numerous test failures in "mtr --ps --embedded"
On Apr 02, Alexey Botchkov wrote:
> > Still, another question, why did you have to rename net_store_data() to
> > net_store_data_cs() ?
> That's personal.
> I really don't like functions with exactly same names - makes code harder to
> understand and debug.
> Do you belive it's better not to rename these here?
That's up to you.
Sometimes I create functions with the same name, sometimes I don't.
For example, tdc_acquire_share() - there are few functions with the same
name, because they do exactly the same. Actually, one of
tdc_acquire_share() is a real function, others are inline convenience
wrappers - they eventually call the "real" one.
But tdc_acquire_share_shortlived() - while also only a convenience
wrapper - has a different name to emphasize that it has different
But anyway, that's your patch. If you'd like to rename - go ahead.