← Back to team overview

maria-developers team mailing list archive

Re: MariaDB 10.3.7 and GSSAPI : Issue


On 26.06.2018 12:00, REIX, Tony wrote:

Hi Wlad,

We are beginners with MariaDB. And we do not master yet CMake, mainly when errors appear. So, since I was unsure about our issue, I did not want to bother with a possibly wrong error. So, talking on this mailing list seemed appropriate to me as a first step. We'll use the MariaDB bug tracker next time, sure.

About the cmake options we used, yes we tried to use several talkative options in order to get detailed traces. Moreover, this issue appears on some machines and not on one machine, and on Linux the code does not run in these lines ; so we were lost about the root cause.

On Linux, the current FindGSSAPI.cmake appears to work, or we would have found and fixed it long ago. The root cause is probably in unusual output of krb5_config on "some machines", that is not processed correctly by cmake -blibpath:/opt/freeware/lib:/usr/lib:/lib -bmaxdata:0x80000000 -brtl . Those are probably those "some" AIX machines, where kerberos is installed.

About gssapi, we are using a .spec file derived from Fedora .spec file for MariaDB ; and probably that there is a way to NOT build with gssapi first, but we missed it at first glance. Looking at the .spec file now, I think that we can try to disable it by means of: %define with_gssapi 0  ; however I still cannot see how the "cmake ..." command can know to NOT look for GSSAPI ; it is still a mystery for me.

our cmake has a (almost)consistent way of dealing with plugins . All server plugins can be switched off with
-DPLUGIN_<NAME>=NO . So to switch off the server side plugin, you can use


Slightly confusingly, a client half of the plugin is built in another repository, client repository, and it has slightly different switch-off rules, thus you also need


So, yes, we asked for help from the CMake guys and they pointed us to this possibly faulty line.

Séna will experiment with:



Sena says, it did not work. With that, you can go back again CMake guys again, because their analysis does not seem to be correct.

Meanwhile, is there a way to say to cmake ... to NOT look at GSSAPI and thus to not run FindGSSAPI.cmake ?

So that we can build and test MariaDB entirely without GSSAPI and come back to this issue later.

Thanks for your help!

A thought - for  cmake beginners,  I think it is the best for you to use cmake like this

cmake . && make

(not like fedora does it in .spec, with hundreds of parameters) . CMake is supposed to be that easy as above, and this short line is supposed to be standard way of using cmake


Tony Reix

ATOS Expert
IBM Coop Architect & Technical Leader
Office : +33 (0) 4 76 29 72 67
1 rue de Provence - 38432 Échirolles - France
www.atos.net <https://mail.ad.bull.net/owa/redir.aspx?C=PvphmPvCZkGrAgHVnWGsdMcDKgzl_dEIsM6rX0g4u4v8V81YffzBGkWrtQeAXNovd3ttkJL8JIc.&URL=http%3a%2f%2fwww.atos.net%2f>
*De :* Vladislav Vaintroub <vvaintroub@xxxxxxxxx>
*Envoyé :* mardi 26 juin 2018 10:09:41
*À :* REIX, Tony; maria-developers@xxxxxxxxxxxxxxxxxxx
*Cc :* APEKE, SENA (ext)
*Objet :* RE: [Maria-developers] MariaDB 10.3.7 and GSSAPI : Issue