maria-developers team mailing list archive
-
maria-developers team
-
Mailing list archive
-
Message #11452
Re: [Commits] 1edec241473: MDEV-17137: Syntax errors with VIEW using MEDIAN
Hi Varun,
On Wed, Sep 12, 2018 at 06:13:23PM +0530, Varun wrote:
> revision-id: 1edec241473a122553fa9a27be995f3aef52654e (mariadb-10.3.7-171-g1edec241473)
> parent(s): 5a1868b58d26b286b6ad433096e7184895953311
> author: Varun Gupta
> committer: Varun Gupta
> timestamp: 2018-09-12 18:10:16 +0530
> message:
>
> MDEV-17137: Syntax errors with VIEW using MEDIAN
>
> The syntax error happened because we had not implemented a different print for
> percentile functions. The syntax is a bit different when we use percentile functions
> as window functions in comparision to normal window functions.
> Implemented a seperate print function for percentile functions
>
...
> diff --git a/sql/item_windowfunc.h b/sql/item_windowfunc.h
> index b3e23748246..268182a2788 100644
> --- a/sql/item_windowfunc.h
> +++ b/sql/item_windowfunc.h
> @@ -1311,6 +1311,7 @@ class Item_window_func : public Item_func_or_sum
> bool resolve_window_name(THD *thd);
>
> void print(String *str, enum_query_type query_type);
> + void print_percentile_functions(String *str, enum_query_type query_type);
>
* Please make this function private
* I think "print_percentile_functions" is a bad name as it implies multiple
functions are printed. In fact, only one function is printed. How about
"print_for_percentile_functions"?
Ok to push after the above is addressed.
BR
Sergei
--
Sergei Petrunia, Software Developer
MariaDB Corporation | Skype: sergefp | Blog: http://s.petrunia.net/blog