← Back to team overview

maria-discuss team mailing list archive

"libmysqlclient.so.18 no version information" issue



I am a relative newbie learning about Linux/MariaDB. I have a test server running Debian Squeeze 6.0.4 with MariaDB 5.5 installed from the MariaDB Squeeze repository. Everything worked great.

I upgraded Squeeze to Wheezy (do have a back up so no issue reverting if necessary). Upgrade went rather smoothly. MariaDB running fine. Everything else working fine.

On the first night after the upgrade, cron ran and I received several errors:

/usr/lib/libmysqlclient.so.18: no version information available (required by exim4) /usr/lib/libmysqlclient.so.18: no version information available (required by /usr/lib/libmu_auth.so.4)

The errors don't seem to cause any problems. I still get the e-mails sent by cron. Exim4 is running fine and I have no problems sending or receiving mail. MariaDB is doing fine and my test websites are performing as expected.

Can someone give me a hint about where to start looking for the solutio to this? I've googled this and really couldn't find much info about it. Is this because the MariaDB deb package from the repo was built against Squeeze? If so, would the error be corrected if I downloaded the source and built it against Wheezy?



Follow ups