← Back to team overview

maria-discuss team mailing list archive

Re: why are ipv6 tests not simply skipped?


sorry for off-list reply, this is caused by get two copies instead
list-only-messages and the duplicate-filter on our mailserver kills
the second one and so no "reply-to-list" available :-(

Am 11.02.2014 14:55, schrieb Sergei Golubchik:
> On Feb 11, Reindl Harald wrote:
>> these tests should be skipped in case the machine has
>> no ipv6 config instead fired up and failing
> I think it depends on ho exactly your machine has "no ipv6 config".
> When I added a check for missing ipv6, my box had no ipv6 at all, not
> compiled into the kernel, no ipv6.ko module either.
> And the check worked, ipv6 tests were skipped.
> Perhaps your machine has "no ipv6 config" differently?
> Then it needs a different check. This is the one that worked for me:
>   use Socket;
>   $skip{'include/check_ipv6.inc'} = 'No IPv6'
>              unless socket SOCK, PF_INET6, SOCK_STREAM, getprotobyname('tcp');
>   close SOCK;
> it's in mysql-test/suite.pm

there is no longer a ko-module in recent kernels for a long time


ifconfig output:
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1472
        inet  netmask  broadcast
        ether 00:50:56:bd:00:17  txqueuelen 500  (Ethernet)
        RX packets 6579586  bytes 2593210501 (2.4 GiB)
        RX errors 0  dropped 5800  overruns 0  frame 0
        TX packets 8932318  bytes 9104600004 (8.4 GiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet  netmask
        loop  txqueuelen 0  (Lokale Schleife)
        RX packets 1756166  bytes 460415712 (439.0 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1756166  bytes 460415712 (439.0 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Attachment: signature.asc
Description: OpenPGP digital signature