← Back to team overview

maria-discuss team mailing list archive

Re: max key length in import


>> I’m considering moving from MySql to MariaDB so I did a dump today and attempted an import.  It failed with the “Specified key was too long; max key length is 767 bytes” error.  I dealt with this in MySql and knew to change file format to Barracuda.  I zapped the partial import, did a fresh mysql_install_db, restarted the service and tried again to no avail.  To confirm my settings immediately after the failure:
> The workaround should be:
> 	set global innodb_large_prefix=on;
> For discussion around this, see: https://answers.launchpad.net/maria/+question/241612

I actually had tried that and received an:
	ERROR 1105 (HY000) at line 16479: Unknown error
So, at a friend’s suggestion, I’m running it again with —verbose so I might be able to see where it crashes.  I also decompressed the file which is now about 6G.  At any rate, we’re beyond where I think it crashed previously, but it’s running very, very slow presumably due to the —verbose.  It looks like it might, eventually, work this way.  Been running for about 12 hours now.

Thanks for the suggestion.