← Back to team overview

maria-discuss team mailing list archive

Re: Missing table rows when importing a MySQL 5.7.8 database into MariaDB 10.4.8 database


Elliot, howdy.

Thanks for narrating it pretty verbose!

I can only suggest to trace or bisect the 600 rows insertion to catch where it



> H Andrei,
> Thanks for the reply. To answer your question when I import the my_dump.sql (yes it does contain
> all 600 rows in that dump file) into a database on the MySQL server (which uses utf8 charset) then
> all works fine. All 600 rows are imported.
> But when I used that same my_dump.sql file to import into a server running MariaDB then only 29
> rows get imported. The MariaDB server is has latin1 as the default character set. So I tried to do
> an alter command on the specific database in question to change it's character set to utf8. When
> that did not work I dropped the database all together and re-created it using the utf8 database
> and that still did not work.
> I run all the commands on the MariaDB server because I wanted to make sure the version of msyql or
> mysqldump was not the issue. Which it does not seem to be the issue since I can export and import
> remotely to the MySQL server just fine (from the MariaDB server)
> On 8/20/20 5:00 AM, andrei.elkin@xxxxxxxxxx wrote:
>             When I use mysqldump to backup a MySQL 5.7.8 database then import that database into a MariaDB
>             10.4.8 database, at least one (maybe more) of the imported tables is missing rows. This is a
>             WordPress database and the table in question is the wp_options table. I'm only getting 29 rows
>             imported when there should be over 600 (in the original MySQL database).
>     Noted, 29 not 600.
>             I'm using the mysqldump and mysql utilities located on the MariaDB server:
>             mysqldump  Ver 10.17 Distrib 10.4.8-MariaDB, for Linux (x86_64)
>             mysql  Ver 15.1 Distrib 10.4.8-MariaDB, for Linux (x86_64) using readline 5.1
>             My steps as performed on the MariaDB server (the server I'm importing to).
>             1. mysqldump -u username -pPassword -h remote_mysql_server database_name > wp_backup.sql
>             2. mysql -u username -pPassword -h localhost database_name < wp_backup.sql
>             When I run mysql (on the local MariaDB server) and import the wp_backup.sql to the
>             remote_mysql_server everything works fine and all rows are importing into a test database out
>             there:
>             mysql -u username -pPassword -h remote_mysql_server database_name < wp_backup.sql
>             So the above works
>     I am guessing it's 29 in 'all' of 'all rows are imported'.
>     Does 
>       wp_backup.sql
>     actually have *all*  600?

Follow ups