← Back to team overview

maria-discuss team mailing list archive

Re: Maria-db refuses to start


Am 10.11.22 um 12:06 schrieb Jogchum Reitsma:
Op 08-11-2022 om 22:54 schreef Daniel Black:
On Wed, Nov 9, 2022 at 12:01 AM Jogchum Reitsma
<jogchum.reitsma@xxxxxxxxx>  wrote:
The directory /var/run/mysql doesn't exist

2022-11-08 13:37:33 0 [ERROR] Do you already have another server running on socket: /var/run/mysql/mysql.sock ?
This guess of an error should be fixed.

Well, in the meantime I have a running database, thanks to all the help I get here.

But I'm not quite out of trouble yet.

The last problem with starting /usr/local/mariadb-10.6.10-linux-systemd-x86_64/bin/mariadbd was solved by chmod 777 /var/run/mysql; this was needed because I start mariadb as a plain user for the moment. chmod on /var/log/msql gave me logging >
Once again I'm at a loss here - what causes mysqld not to start?

Any further help dearly appreciated....

either "in the meantime I have a running database" or "what causes mysqld not to start" are possible and when it comes to "chmod on /var/log/msql gave me logging" show them

for the sake of god open "/usr/lib/systemd/system/mariadb.service" and remove or comment out the "ExecStartPre" until your problems are solved

"ExecStartPre=/usr/libexec/mysql/mysql-systemd-helper upgrade (code=exited, status=1/FAILURE)" is some distribution sepcific nonsense

in the real world it's enoug to ExecStart mysqld as user:ggroup mysql and skip all that nonsense including mysql_safe

Follow ups