openerp-expert-framework team mailing list archive
-
openerp-expert-framework team
-
Mailing list archive
-
Message #00106
Re: object namespaces
On Thursday 14 January 2010, David Janssens wrote:
> Related to the 'removing context' issue:
> In a later version, would it be possible to replace all the
> self.pool.get("xxx").blabla(...) by just xxx.blabla(...) ?
> I mean using regular python object namespaces rather than pool.get?
> It would reduce the required typing...
>
It could be much harder than it originally sounds.
Consider that most names don't just have one part, but dotted notation:
self.pool.get('account.invoice')
Then, we should create an intermediate 'account' object that would resolve the
'invoice' one. When it comes to the structuring of that dotted notation (does
'invoice' belong to the 'account' module? ), things may get even more messy..
Follow ups