← Back to team overview

openlp-core team mailing list archive

Re: [Merge] lp:~crichter/openlp/media_rewrite into lp:openlp

 

Review: Needs Fixing
plugin.display_css()
plugin.display_javascript()
plugin.display_html()

1. These functions are poorly named. What does "display_css" mean? Does this function actually display CSS? Surely these functions should rather be called "get_css" or "get_display_css"

2. Plugin is a QObject-based class, therefore, like the rest of the functions in the Plugin class, your display_* functions should be getDisplayCss, getDisplayJavaScript and getDisplayHtml.
-- 
https://code.launchpad.net/~crichter/openlp/media_rewrite/+merge/63916
Your team OpenLP Core is subscribed to branch lp:openlp.


References