← Back to team overview

openstack team mailing list archive

Re: vlan setup and cisco switch

 

Hi Kiall,

 

I have testbed OpenStack and Nexus Switch with the following configuration: 

 

interface Ethernet3/15

  switchport

  switchport access vlan 10

  no shutdown

 

interface Ethernet3/16

  switchport

  switchport access vlan 10

  no shutdown

 

(In your case will be VLAN 100)

You don't really need to have your ports in trumk mode unless you are working with different VLANs. In that case Miguel's configuration should work as well.

 

Thanks,

Edgar

 

From: openstack-bounces+eperdomo=cisco.com@xxxxxxxxxxxxxxxxxxx [mailto:openstack-bounces+eperdomo=cisco.com@xxxxxxxxxxxxxxxxxxx] On Behalf Of Kiall Mac Innes
Sent: Wednesday, November 16, 2011 9:54 PM
To: Miguel Alejandro González
Cc: openstack@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Openstack] vlan setup and cisco switch

 

I've not used VLAN's with Cisco switches, so I could be wrong here..

 

switchport mode trunk

switchport trunk native vlan 1 (This is the vlan that un-tagged packets will go to..)
switchport trunk allowed vlan 100-115 (Since you created 16 networks, they will be vlan's 100-115)


Thanks,
Kiall



2011/11/17 Miguel Alejandro González <maggonzz@xxxxxxxxx>

Hello

It's been a while since I configured a cisco switch myself. I'm wondering if you can help me... I'm trying to use vlan networking

I have installed two nodes and my eth0 in both nodes goes to a cisco 2960 switch, to ports 1 and 3

I used this command to create the network:

nova-manage network create --multi_host T --network_size 16 --num_networks 16 --bridge_interface eth0 --fixed_range_v4 172.16.0.0/12 --label internal




 
 
 
 

Here's my setup

server1
nova (all)
glance
keystone
horizon

server2
nova(compute, volume and network)

The nodes show the vlan100 interface so I think so far the problem I'm having relies on the switch... maybe i haven't configured it correctly....

Here's an ifconfig: http://pastebin.com/A3Z3tJz2

On the switch, I created vlan100 with a command like:
vlan 100 name cloud

Then configured the ports with:
interface range fastethernet 0/1-4
switchport mode access vlan 100

This didn't work, so i was told i needed to enable Trunk mode. So I did with:
interface range fastethernet 0/1-4
switchport mode trunk
switchport trunk native vlan 100

But somehow i think im doing something in the switch, so that's why I'm asking you guys

I hope you can help me...

Regards







_______________________________________________
Mailing list: https://launchpad.net/~openstack
Post to     : openstack@xxxxxxxxxxxxxxxxxxx
Unsubscribe : https://launchpad.net/~openstack
More help   : https://help.launchpad.net/ListHelp

 


References