← Back to team overview

openstack team mailing list archive

libvirt + kvm problem on ubuntu 10.04.3



I'm facing a strange problem with libvirt + kvm on Ubuntu 10.04.3.

I have all-in-one installation of Essex-2. When I start an instance
using 'nova boot', it shows its status as ACTIVE, but when I connect
using vnc (by issuing 'vncdisplay' command in virsh for that instance),
I can see it doesn't even boot and shows

'No bootable device' error.

Here's the output of 'virsh dumpxml' for that instance and also
libvirt's log file:


I also have a VM I spawned manually (i.e. not through on this box) and
it works fine. Here's its log:


The only major difference I can see is that it's using 'boot=on' for
drive. It's also not using kernel and initrd, but I've tried images with
out it with the same result.

I've also been experimenting with running kvm manually and found a
reproducible crash:

root@host:/var/log/libvirt/qemu# LC_ALL=C
QEMU_AUDIO_DRV=none /usr/bin/kvm -S -M pc-0.12 -enable-kvm -m 512 -smp
1,sockets=1,cores=1,threads=1 -name instance-0000006d -uuid
0ce3afdc-be2f-4079-d106-e70b287f9e26 -nodefaults -chardev
-mon chardev=charmonitor,id=monitor,mode=readline -rtc base=utc -boot c
-kernel /var/lib/nova/instances/instance-0000006d/kernel -initrd
/var/lib/nova/instances/instance-0000006d/ramdisk -append root=/dev/vda
-device isa-serial,chardev=charserial0,id=serial0 -chardev
pty,id=charserial1 -device isa-serial,chardev=charserial1,id=serial1
-usb -vnc -k en-us -no-kvm
char device redirected to /dev/pts/20
Segmentation fault

It segfaults when I'm connecting to it via VNC.

I'm kind of stuck with this issue and have no idea how to debug it further.
Any ideas how that could be fixed?

Roman Bogorodskiy

Attachment: pgpX2j9gwBrgD.pgp
Description: PGP signature

Follow ups