← Back to team overview

openstack team mailing list archive

Re: libvirt + kvm problem on ubuntu 10.04.3


Hi Roman,

our StackOps Distro is based in 10.04 and we had to modify some packages to
make  Diablo work with kvm: we changed qemu-kvm 0.12 to 0.14:

- qemu-common_0.14.0 and
- qemu-kvm_0.14.0.

Don't know if it can help, but you can give a try...


Diego Parrilla
*www.stackops.com | * diego.parrilla@xxxxxxxxxxxx** | +34 649 94 43 29 |
* <http://www.stackops.com/>


******************** ADVERTENCIA LEGAL ********************
Le informamos, como destinatario de este mensaje, que el correo electrónico
y las comunicaciones por medio de Internet no permiten asegurar ni
garantizar la confidencialidad de los mensajes transmitidos, así como
tampoco su integridad o su correcta recepción, por lo que STACKOPS
TECHNOLOGIES S.L. no asume responsabilidad alguna por tales circunstancias.
Si no consintiese en la utilización del correo electrónico o de las
comunicaciones vía Internet le rogamos nos lo comunique y ponga en nuestro
conocimiento de manera inmediata. Este mensaje va dirigido, de manera
exclusiva, a su destinatario y contiene información confidencial y sujeta
al secreto profesional, cuya divulgación no está permitida por la ley. En
caso de haber recibido este mensaje por error, le rogamos que, de forma
inmediata, nos lo comunique mediante correo electrónico remitido a nuestra
atención y proceda a su eliminación, así como a la de cualquier documento
adjunto al mismo. Asimismo, le comunicamos que la distribución, copia o
utilización de este mensaje, o de cualquier documento adjunto al mismo,
cualquiera que fuera su finalidad, están prohibidas por la ley.

***************** PRIVILEGED AND CONFIDENTIAL ****************
We hereby inform you, as addressee of this message, that e-mail and
Internet do not guarantee the confidentiality, nor the completeness or
proper reception of the messages sent and, thus, STACKOPS TECHNOLOGIES S.L.
does not assume any liability for those circumstances. Should you not agree
to the use of e-mail or to communications via Internet, you are kindly
requested to notify us immediately. This message is intended exclusively
for the person to whom it is addressed and contains privileged and
confidential information protected from disclosure by law. If you are not
the addressee indicated in this message, you should immediately delete it
and any attachments and notify the sender by reply e-mail. In such case,
you are hereby notified that any dissemination, distribution, copying or
use of this message or any attachments, for any purpose, is strictly
prohibited by law.

On Thu, Feb 9, 2012 at 1:59 PM, Roman Bogorodskiy <bogorodskiy@xxxxxxxxx>wrote:

> Hi,
> I'm facing a strange problem with libvirt + kvm on Ubuntu 10.04.3.
> I have all-in-one installation of Essex-2. When I start an instance
> using 'nova boot', it shows its status as ACTIVE, but when I connect
> using vnc (by issuing 'vncdisplay' command in virsh for that instance),
> I can see it doesn't even boot and shows
> 'No bootable device' error.
> Here's the output of 'virsh dumpxml' for that instance and also
> libvirt's log file:
> http://dpaste.de/VeFeq/
> I also have a VM I spawned manually (i.e. not through on this box) and
> it works fine. Here's its log:
> http://dpaste.de/cp4C1/
> The only major difference I can see is that it's using 'boot=on' for
> drive. It's also not using kernel and initrd, but I've tried images with
> out it with the same result.
> I've also been experimenting with running kvm manually and found a
> reproducible crash:
> root@host:/var/log/libvirt/qemu# LC_ALL=C
> PATH=/usr/local/sbin:/usr/local/bin:/usr/bin:/usr/sbin:/sbin:/bin
> QEMU_AUDIO_DRV=none /usr/bin/kvm -S -M pc-0.12 -enable-kvm -m 512 -smp
> 1,sockets=1,cores=1,threads=1 -name instance-0000006d -uuid
> 0ce3afdc-be2f-4079-d106-e70b287f9e26 -nodefaults -chardev
> socket,id=charmonitor,path=/var/lib/libvirt/qemu/instance-0000006d.monitor,server,nowait
> -mon chardev=charmonitor,id=monitor,mode=readline -rtc base=utc -boot c
> -kernel /var/lib/nova/instances/instance-0000006d/kernel -initrd
> /var/lib/nova/instances/instance-0000006d/ramdisk -append root=/dev/vda
> -drive
> file=/var/lib/nova/instances/instance-0000006d/disk,if=none,id=drive-virtio-disk0,format=qcow2,boot=on
> -device
> virtio-blk-pci,bus=pci.0,addr=0x4,drive=drive-virtio-disk0,id=virtio-disk0
> -chardev
> file,id=charserial0,path=/var/lib/nova/instances/instance-0000006d/console.log
> -device isa-serial,chardev=charserial0,id=serial0 -chardev
> pty,id=charserial1 -device isa-serial,chardev=charserial1,id=serial1
> -usb -vnc -k en-us -no-kvm
> char device redirected to /dev/pts/20
> Segmentation fault
> root@host:/var/log/libvirt/qemu#
> It segfaults when I'm connecting to it via VNC.
> I'm kind of stuck with this issue and have no idea how to debug it further.
> Any ideas how that could be fixed?
> Roman Bogorodskiy
> _______________________________________________
> Mailing list: https://launchpad.net/~openstack
> Post to     : openstack@xxxxxxxxxxxxxxxxxxx
> Unsubscribe : https://launchpad.net/~openstack
> More help   : https://help.launchpad.net/ListHelp

Follow ups