← Back to team overview

openstack team mailing list archive

Re: [devstack] unknown url type: git+https in quantum pipdependencies




Workarounds suggested. Just tried and it worked.





From: openstack-bounces+roagarwa=cisco.com@xxxxxxxxxxxxxxxxxxx [mailto:openstack-bounces+roagarwa=cisco.com@xxxxxxxxxxxxxxxxxxx] On Behalf Of Nicolas de BONFILS
Sent: Friday, March 23, 2012 10:50 AM
To: openstack@xxxxxxxxxxxxxxxxxxx
Subject: [Openstack] [devstack] unknown url type: git+https in quantum pipdependencies


Hi stackers,

I use devstack to install, and got the following error :

	+ cd /home/nicolas/openstack/quantum
	+ sudo python setup.py develop
	running develop
	Checking .pth file support in /usr/local/lib/python2.7/dist-packages/
	/usr/bin/python -E -c pass
	TEST PASSED: /usr/local/lib/python2.7/dist-packages/ appears to support .pth files
	running egg_info
	creating quantum.egg-info
	writing requirements to quantum.egg-info/requires.txt
	writing quantum.egg-info/PKG-INFO
	writing eager_resources to quantum.egg-info/eager_resources.txt
	writing top-level names to quantum.egg-info/top_level.txt
	writing dependency_links to quantum.egg-info/dependency_links.txt
	writing entry points to quantum.egg-info/entry_points.txt
	writing manifest file 'quantum.egg-info/SOURCES.txt'
	reading manifest file 'quantum.egg-info/SOURCES.txt'
	reading manifest template 'MANIFEST.in'
	writing manifest file 'quantum.egg-info/SOURCES.txt'
	running build_ext
	Creating /usr/local/lib/python2.7/dist-packages/quantum.egg-link (link to .)
	quantum 2012.2 is already the active version in easy-install.pth
	Installing quantum-linuxbridge-agent script to /usr/local/bin
	Installing quantum-openvswitch-agent script to /usr/local/bin
	Installing quantum-ryu-agent script to /usr/local/bin
	Installing quantum-server script to /usr/local/bin
	Installed /home/nicolas/openstack/quantum
	Processing dependencies for quantum==2012.2
	Searching for python-quantumclient
	Best match: python-quantumclient [unknown version]
	Downloading git+https://review.openstack.org/p/openstack/python-quantumclient#egg=python-quantumclient
	error: Download error for git+https://review.openstack.org/p/openstack/python-quantumclient: unknown url type: git+https
	++ failed
	++ local r=1
	++ set +o xtrace

Its seems that the git+https protocol is not recognize. I tried to google it and find no reference. Do I need to install git review to download those files ?

Thanks for the help




Follow ups