← Back to team overview

openstack team mailing list archive

Re: regarding this Message #09165 (VNC error with latest version of Firefox)


In diablo, nova shipped its own websocket proxy, which had some browser
compatibility issues due to eventlet's out-dated websocket implementation.
 For this reason, in essex we replaced nova-vncproxy with one more directly
based on noVNC's websocket proxy.  Docs for the current proxy may be found

At the time of diablo release, I had an early version of the current proxy
working against stable/diablo here:
https://github.com/cloudbuilders/noVNC/branches/diablo - devstack's
stable/diablo shows how to use that branch.

I just ran the branch mentioned above against diablo + Firefox 11 - seems
to work.  I would expect the 'official' diablo vnc proxy to have browser
compat issues, though I have not tried your exact configuration.


On Wed, Mar 28, 2012 at 6:09 AM, Staicu Gabriel <gabriel_staicu@xxxxxxxxx>wrote:

> Hi Diego,
> I observed the same behavior as you.
> I am using the latest packages from http://ops.rcb.me/packages.
> Everything works fine except the connection to vnc console from the latest
> firefox (11.0) on linux. I tried also with firefox 11.0 from win7 and the
> error is the same.
> What workaround I found till now is to use firefox (10.0.3) which works ok.
> Regards,
> Gabriel
> _______________________________________________
> Mailing list: https://launchpad.net/~openstack
> Post to     : openstack@xxxxxxxxxxxxxxxxxxx
> Unsubscribe : https://launchpad.net/~openstack
> More help   : https://help.launchpad.net/ListHelp

Follow ups