← Back to team overview

openstack team mailing list archive

Re: even after deleting all container , , , it shows high disk space usges



Your email and the problem you described puzzled me.
I think I realize what had happened, but not sure.

First a background question:
1. what is the replication ratio used in your cluster?
   You indicated an SAIO - so you must have 3 replicas, but I am still not
sure how all that had happened with 3 replicas (makes some more sense with

Next, please find out where your swift installation stores the data:
`grep -r devices /etc/swift` will give you one or more directories - e.g.
on my system it is:
/etc/swift/container-server/3.conf:devices = /srv/3/node
/etc/swift/container-server/2.conf:devices = /srv/2/node
/etc/swift/container-server/4.conf:devices = /srv/4/node
/etc/swift/container-server/1.conf:devices = /srv/1/node
/etc/swift/object-server/3.conf:devices = /srv/3/node
/etc/swift/object-server/2.conf:devices = /srv/2/node
/etc/swift/object-server/4.conf:devices = /srv/4/node
/etc/swift/object-server/1.conf:devices = /srv/1/node
/etc/swift/account-server/3.conf:devices = /srv/3/node
/etc/swift/account-server/2.conf:devices = /srv/2/node
/etc/swift/account-server/4.conf:devices = /srv/4/node
/etc/swift/account-server/1.conf:devices = /srv/1/node

Next look into the different tmp files of the different disks
2. Do you see a 4.5 G file in tmp? If so please indicate what files did you
find and where.
(on my system I would be looking at /srv/*/node/*/tmp)

3. What is your disk configuration? Which disk serves as the swift device
for objects? How much disk space do you have available? You need 13.5GB to
serve a 4.5GB file with replication level of three.

See below.

> From: Study Kamaill <study.info@xxxxxxxxx>
> To: Thierry Carrez <thierry@xxxxxxxxxxxxx>,
> "openstack@xxxxxxxxxxxxxxxxxxx" <openstack@xxxxxxxxxxxxxxxxxxx>,
> Date: 21/05/2013 09:44 AM
> Subject: [Openstack] even after deleting all container , , , it
> shows high disk space usges
> Sent by: "Openstack" <openstack-bounces
> hi ,
> Can anyone help me .....
> i have four storage node in my experimental setup. (all in one swift
> setup)  when i tried to  upload a file of size 4.5GB it was taking
> too long to upload so i terninated that job...

This is alarming, can you check the log files to see what went on?
Could it be that your disk became full?

> I tried to to check the container where did i upload that. It was
> showing nothing.
> Later i tried to check the disk space usages .. it shows the system
> is using 4.5 gb there on those node.

I cant get it why 4.5...
Maybe something went bad in one replica, but than if you have three, you
should have received an OK after the other two completed...
This is where I became really puzzled.

> I tried to delete all container owned by that user.

If the object is not listed in the container, this would have no affect.

> but still  i am not able to figure it out that .. how to remove all
> content from my node..

I would search it in the tmp dirs (see above) first, given that Swift never
responded with 201 Created

> regards,
> AShish
> _______________________________________________
> Mailing list: https://launchpad.net/~openstack
> Post to     : openstack@xxxxxxxxxxxxxxxxxxx
> Unsubscribe : https://launchpad.net/~openstack
> More help   : https://help.launchpad.net/ListHelp