← Back to team overview

sikuli-driver team mailing list archive

Re: [Question #176537]: Organizing Sikuli scripts, that represent tests

 

Question #176537 on Sikuli changed:
https://answers.launchpad.net/sikuli/+question/176537

RaiMan posted a new comment:
--- The ideal case for me is to have an img folder on the level of the
.sikuli folder

Here you are:

*** the image folder as .sikuli (e.g. myImages.sikuli)

# contains any organization Python allows

"some-image.png" # case 1
some_image = "cryptic-name.png" # case 2
some_other_image = { "resLow" : "low-res.png", "resHigh" : "high-res.png"} # case 3

# ... and many other possibilities including classes or interfaces to
any kind of image databases

You edit and manage this in the IDE. It needs some naming convention to
be effective (but that is true for every modularized programming)

-- usage

from myImages import * # this makes the images itself and all definitions available
find("some-image.png" ) # case 1
find(some_image) # case 2
find(some_other_image["resLow"])

find(getImage("some-image")) # implemented as class or db-interface

The docs in the chapter "Reusing ..." might help with the Sikuli
specific backgrounds

You received this question notification because you are a member of
Sikuli Drivers, which is an answer contact for Sikuli.