← Back to team overview

ubuntu-389-directory-server team mailing list archive

Re: I've encountered three more issues. misconfigured libs/settings, and a segfault on starting admin server. Here's all the relevant information:


30.12.2011 13:22, Timo Aaltonen kirjoitti:
> 30.12.2011 02:16, Christ Schlacta kirjoitti:
>> So three issues.  First some preamble.  I've been having a go of
>> installing 389 on centos, ubuntu, and fedora.  So far centos is the only
>> one that went off without a hitch :(  I'm running all of them in kvm
>> virtual machines on ubuntu oneiric.
>> At the bottom of this e-mail is some useful information about my system,
>> if you need anything else, feel free to ask.
>> the first issue is a missing dependency on apache2.  without the apache2
>> package, the setup process fails, though I can't remember where.  I've
>> since included it in my install/purge lists every time I try to re-run
>> the install process.
> Yes, there will be a metapackage called "389-ds" which will make
> installing easier, though the apache2 dependency should be in one of the
> real packages. I'll fix it.
>> The second issue is some misconfigured libraries somewhere during
>> scripting or install.  I'm not really sure where the problem is, but
>> there's a simple workaround, shown below.
> Right, seems that 389-admin is not multiarchified yet, so the script is
> looking at the wrong path.
>> the third issue is a segfault when running start-ds-admin .  I've tried
>> a little hacking to further identify the issue, but haven't been able to
>> identify it.  Simply, a segmentation fault occurs.  I apologize for not
>> having more information.
> I haven't tried it myself, could be a symptom of the above. Maybe I
> won't be able to fix the issues until next week, but we'll see..

I lied, fixed the packaging issues and uploaded a new 389-admin. Setup
works fine, but accessing the web configurator fails with the htmladmin
cgi-bin script crashing:

[Fri Dec 30 20:57:09 2011] [error] [client] Premature end
of script headers: htmladmin, referer:

Dec 30 20:57:09 389ds kernel: [ 9945.600254] htmladmin[17904] general
protection ip:403a19 sp:7fffb91ccbb0 error:0 in htmladmin[400000+7000]

dunno why that happens, any help debugging it is welcome :)

Follow ups