← Back to team overview

ubuntu-multiseat team mailing list archive

Re: Xubuntu 14.10 second seat screen lock not working / gets stuck


Hi Richard,

thanks for the quick reply (on 31.12 no less)! I am actually totally amazed
at the near-perfect state of multiseat in Ubuntu. This light-locker issue
seems so far to be the ONLY problem! So fo sure you all deserve a lot of
respect for this great work!

On 31 December 2014 at 22:27, Richard Hansen <ubuntu-a7x@xxxxxxxxxxxxxxx>
> (It'd be good if we had the above in a "Contact Us" wiki page.)

I contacted you via the "Contact the team admins" link on
https://launchpad.net/~ubuntu-multiseat, I first wanted to open a bug but
could not quickly find the way how to "just" open a new bug on launchpad
without using the ubuntu-bug program.

I did not send a mail to the list because on that page it says that the
list is members-only (or I confused subscribe with post to).

> >
> > I have the impression that Xubuntu 14.10 does not support screen locking
> > on seats other than seat0.
> >
> > What I observe is that if the screen locks it goes to the "This session
> > is locked. You'll be redirected ..." message but stays there forever. I
> > suspect that the main reason is the fact that lightdm cannot start
> > another X server on this seat (VT switching beeing supported only on
> > seat0).
> >
> > I tried telling lightdm via a seat-specific configuration that it cannot
> > to user switching. As a result locking does not work at all (also bad)
> > and the seat stays dead after the users logs out.
> The screen locker/saver should only attempt VT switching if you click on
> the "switch users" button (VT switching isn't involved when just trying
> to unlock the screen).  So my guess is that VT switching isn't related
> to the problem you're having.

​I don't understand. According to
http://xubuntu.org/news/screen-locking-in-xubuntu-14-04/ light-locker
heavily depends on lightdm beeing able to spawn another X server on the
card and use VT switching to show that to the user. AFAIKT this does not
work on secondare seats hence light-locker won't work there.

> My guess is that the problem stems from the lack of logind support.  See:
>     https://bugs.kde.org/show_bug.cgi?id=314989
> According to that bug, logind integration is in plasma-workspace 5.x and
> won't be backported to kde-workspace 4.x.

​How does this relate to the use case of XFCE, lightdm and multiseat? I
actually could unlock the session with loginctl unlock-session (as root).

It seems to me rather that light-locker just locks the session with the
"This session is locked" but then lightdm cannot show the greeter anywhere
to ask for a passwort to unlock it.

I read somewhere that there is an open issue that lightdm assumes the
secondary seat to support User Switching (which it actually does not).
dm-tool also shows this:

$ dm-tool list-seats

That is why I tried adding this to lightdm.conf:


The effect was that Seat1 would not show as CanSwitch=true in dm-tool
list-seats. And that light-locker would not lock the session any more (no
more stuck on "This session is locked"). Which is good since the user
cannot lock himself out any more. But the downside is that then it is
impossible to lock the screen in Xubuntu and that after logging out of the
session there is no new login screen. Apparently lightdm does not start a
new session on this seat after the first session is done.

The reason I am contacting you as the mutliseat team is that I wanted to
find out if anybody is aware of this issue (locking secondary seats with
lightdm and light-locker) and working on it, at least conceptually.

It seems to me that the current locking concept (using lightdm to show a
*new* greeter to unlock) does not cover this use case at all :-(

If you say that I am the first one to observe this conflict then I'll be
happy to open a bug report about it as you suggest (against which

My workaround is now to use xscreensaver instead of light-locker. Works but
ugly and much less integrated.

Testing daily images won't work since this is already a production system
with a high WAF requirement and I don't have another system for testing
(yet). Do you know about a good way to test this in a virtual machine
instead of real hardware?

Kind Regards,

Follow ups