← Back to team overview

ubuntu-phone team mailing list archive

Re: Setting up a developer environment


Thanks for the responses.

I'm only able to work this an hour or so here and there, so it
may take awhile to reach my goal.

Yesterday and today I tried to get an external disk mounted via
USB on the M10. No joy. I tried 2,3 and 4TB disks. I have a
special cable that connects to the M10's USB port and has a
female standard USB on the other side. I've tried connecting
a disk direct to this; I have also instead connected a USB
hub to that and then plugged the drive into the hub.

I know the hub is working because I have a keyboard and mouse
on it and the M10 recognizes them. However, it does not appear
to even notice the drives are there. Nothing shows up in /dev/sd*
other than the onboard sda; unfortunately there is no lsusb
command available so I have not yet figured out how to check
to see if the USB subsystem even sees it. I'm sure one of the
/proc files has the info and I will look tomorrow.

Every disk I have tried 'lights up', so they are at least
getting powered by the M10.

Any suggestions? I know this works if you get the cables right
because I had it working a year ago. Unfortunately something
important is missing from my notes because I am unable (so far)
to replicate.

|   Dale Amon                  Immortal Data                    |
|   CEO             Midland International Air and Space Port    |
| amon@xxxxxxx       "Data Systems for Deep Space and Time"     |