← Back to team overview

unity-dev team mailing list archive

[Ayatana-dev] Naming of QSortFilterProxyModelQML in unity-2d

 

The C++ class that acts as a wrapper for the QSortFilterProxyModel is
called 'QSortFilterProxyModelQML', which seems fine to me. However,
the QML class is also called 'QSortFilterProxyModelQML' and that seems
a bit ugly.

So in the QML we have this:

QSortFilterProxyModelQML {
    id: filteredByWorkspace
    ...
}

But wouldn't this look a bit more 'qml-like'?

SortFilterProxyModel {
    id: filteredByWorkspace
    ...
}

It is named in libunity-2d-private/Unity2d/plugin.cpp:

void Unity2dPlugin::registerTypes(const char *uri)
{
    qmlRegisterType<QSortFilterProxyModelQML>(uri, 0, 1,
"QSortFilterProxyModelQML");
...

So it would be easy to change.

-- Richard



Follow ups