← Back to team overview

yade-users team mailing list archive

public interface change for dispatchers

 

Hello,

I just commited changeset that removes the
dispatcher->add(string,string,string) function from
MetaDispatchingEngine, like
    
engine->add("InteractingSphere","InteractingSphere","InteractingSphere2InteractingSphere4SpheresContactGeometry")

All EngineUnits (like InteractingSphere2InteractingSphere4...) declare
types they dispatch for using FUNCTOR1D or FUNCTOR2D macro in the
header. I adapted all FileGenerators to that change and verified they
compile (if I made a typo, it will be a runtime error, though).

Hence, the above example will now take on of the following forms:

 1.
engine->add("InteractingSphere2InteractingSphere4SpheresContactGeometry")
 2. engine->add(new
InteractingSphere2InteractingSphere4SpheresContactGeometry)
 3. engine->add( [ the same, but with shared_ptr to that type ] ).

Hope that will make creating engines on the rootbody a lot more readable.

Vaclav





_______________________________________________
Yade-users mailing list
Yade-users@xxxxxxxxxxxxxxxx
https://lists.berlios.de/mailman/listinfo/yade-users