yade-users team mailing list archive
-
yade-users team
-
Mailing list archive
-
Message #02793
Re: Simulation in displacement control
> BTW, why sometimes I do not see consistence in assigned names of py/c
> ++ functions? Like getMove() and move()... It would be simpler to
> maintain the same...
In this particular case, I wanted to keep it as short as possible in
python (f,t,move,rot), thinking that it will be frequently used to read
things, while the contrary (add*) will be used rather rarely. In c++, it
was matter of being clear. But I am open to suggestions here, really.
BTW, it would also be nice to change O.forces.t(2) to O.forces[2].t,
perhaps even supporting += on those things (O.forces[2].t+=4, instead of
O.forces.addT(2,4) ). It would be more consistent with how bodies and
interactions work (though quite far from how it is underneath in c++).
Cheers, v.
References