← Back to team overview

yade-users team mailing list archive

Re: [Question #698948]: Stability of advection modeling by ThermalEngine


Question #698948 on Yade changed:

Robert Caulk proposed the following answer:
Hey Zoheir,

This is quite odd: applyTempDeltaToSolids is deactivated by default: the
user needs to manually set thermal.delT>0 for that function to activate
[1]. As you see in [1], thermal.delT is set to 0 if user does nothing. So
compiling without the line you indicated will change nothing in the output
unless your user script manually activated thermal.delT>0. I don’t see you
setting that value in any of the MWEs that you provided here. So this
cannot be the issue (unless you are using a different script to the one
provided here where you use delT).

Can you please find the unstable packing, then export those sphere radii
and location to text file, the copy paste that file to this thread so I can
replicate exactly your problem. Also please copy paste the identical script
that goes with running that packing.

Then please type here the exact output of yade -v where yade is the
executable you are using (it may be named differently depending on how you
compile or which package you download).



[1] https://gitlab.com/yade-dev/trunk/-/blob/master/pkg/pfv/Thermal.hpp#L133

Le mar. 19 oct. 2021 à 23:01, Zoheir Khademian <
question698948@xxxxxxxxxxxxxxxxxxxxx> a écrit :

> Question #698948 on Yade changed:
> https://answers.launchpad.net/yade/+question/698948
> Zoheir Khademian posted a new comment:
> Hey Robert,
> Sorry for my delays. I try to give your comments enough thoughts and do
> investigation before replying.
> I tried both released version [1] and development version [2] and still
> observed the instabilities meaning the particle temp goes above the max
> boundary temp while cell temp is still within the range.
> Regarding the diffusivity coefficient kA/L, in the MWE I uploaded last, I
> have reduced  kA/L by reducing fluidk and fluidConductionAreaFactor to
> arbitrarily low values. I also tried your values
> (thermal.minimumFluidCondDist=rMean and
> thermal.fluidConductionAreaFactor=0.1) but still the particle temp is
> unstable.
> Finally I looked at the thermal.cpp and noticed that
> applyTempDeltaToSolids [3] adds pore temp differences to the solid temp
> for no apparent reason (particle temp is updated here [4]). I
> deactivated applyTempDeltaToSolids and recompiled the source. I ran the
> MWE and the results are stable now.
> Let me know if applyTempDeltaToSolids must not be deactivated or I am
> missing something here
> Thanks
> Zoheir
> [1] https://launchpad.net/yade/+download
> [2] https://gitlab.com/yade-dev/trunk
> [3] https://gitlab.com/yade-
> dev/trunk/-/blob/master/pkg/pfv/Thermal.cpp#L94
> [4] https://gitlab.com/yade-
> dev/trunk/-/blob/master/pkg/pfv/Thermal.cpp#L605
> --
> You received this question notification because your team yade-users is
> an answer contact for Yade.
> _______________________________________________
> Mailing list: https://launchpad.net/~yade-users
> Post to     : yade-users@xxxxxxxxxxxxxxxxxxx
> Unsubscribe : https://launchpad.net/~yade-users
> More help   : https://help.launchpad.net/ListHelp

You received this question notification because your team yade-users is
an answer contact for Yade.