← Back to team overview

yade-users team mailing list archive

Re: [Question #699714]: Python problems in Yade 2021.01a


Question #699714 on Yade changed:

    Status: Needs information => Answered

Jan Stránský proposed the following answer:
I have installed 2021.01a (although on Ubuntu 18.04)

> about running scripts i should say that for me there is not change and
in all cases the error exists.

to be sure, could you please post here the exact script you are using?
For me, this script
for kk in c:
    a=[x/max(kk) for x in kk]
works without any error. Run as
yade-2021.01a script.py
It gives the error you reported if used in "fresh| Yade console started as "yade-2021.01a".

(interestingly) If I run any (even empty) script first, then also using
just the console gives no error.

> I tried to present a MWE.

yes, for the "console error" the code you provided was a perfect MWE,

> but what it might help is that the ConcretePM.cpp file for Yade 2021
is quit different from ConcretePM.cpp file for YADE 2018 as i compare
them. as you suggested previously, by decrease of time step the
simulation can continue more steps but again it interrupted with the
same error (Aborted (core dumped)).

this probably is a different issue than python 2 / 3 (although there might be situations leading to differences, like if there is integer division in python 2 or python 3). Impossible to tell without a MWE, or at least the script used, if not minimal :-)
So probably you should open a new question concerning the CPM part of your problem.


You received this question notification because your team yade-users is
an answer contact for Yade.