yahoo-eng-team team mailing list archive
-
yahoo-eng-team team
-
Mailing list archive
-
Message #07751
[Bug 1264111] [NEW] Passing driver name to a driver in order to use driver with different configurations
Public bug reported:
For the ability to use same lbaas driver with different configurations,
driver name (or actually configuration name) should be passed to a
driver when instantiating it.
Different configuration options will be used when with same driver by
just changing the name of service provider.
For example:
service_provider=LOADBALANCER:radware:neutron.services.loadbalancer.drivers.radware.driver.LoadBalancerDriver
or
service_provider=LOADBALANCER:radwareHA:neutron.services.loadbalancer.drivers.radware.driver.LoadBalancerDriver
#neutron.cong
..
[radware]
..
[radwareHA]
** Affects: neutron
Importance: Undecided
Assignee: Evgeny Fedoruk (evgenyf)
Status: New
** Tags: config driver lbaas neutron
** Changed in: neutron
Assignee: (unassigned) => Evgeny Fedoruk (evgenyf)
--
You received this bug notification because you are a member of Yahoo!
Engineering Team, which is subscribed to neutron.
https://bugs.launchpad.net/bugs/1264111
Title:
Passing driver name to a driver in order to use driver with different
configurations
Status in OpenStack Neutron (virtual network service):
New
Bug description:
For the ability to use same lbaas driver with different
configurations, driver name (or actually configuration name) should be
passed to a driver when instantiating it.
Different configuration options will be used when with same driver by
just changing the name of service provider.
For example:
service_provider=LOADBALANCER:radware:neutron.services.loadbalancer.drivers.radware.driver.LoadBalancerDriver
or
service_provider=LOADBALANCER:radwareHA:neutron.services.loadbalancer.drivers.radware.driver.LoadBalancerDriver
#neutron.cong
..
[radware]
..
[radwareHA]
To manage notifications about this bug go to:
https://bugs.launchpad.net/neutron/+bug/1264111/+subscriptions
Follow ups
References