← Back to team overview

zim-wiki team mailing list archive

Re: problems installing zim0.55 on mac OS 10.7.3


Thanks for the reply!

On Wed, Feb 29, 2012 at 6:48 PM, Jaap Karssenberg
<jaap.karssenberg@xxxxxxxxx> wrote:
> On Wed, Feb 29, 2012 at 7:46 PM, Robert Corty <rcorty@xxxxxxxxx> wrote:
>> This is my first post on this mailing list.  If this is not the right
>> place to ask technical questions, I apologize.  Please just tell me
>> the right place to ask them and don't unleash a huge ragefest on me.
> Yes this is the right place to ask.
>> I read through the information about zim and it looks like it would be
>> really useful to help me organize my note-taking (I'm in medical
>> school).  I have a mac running OS 10.7.3.
>> I installed MacPorts and typed "sudo port install [port-name]" at the
>> terminal for the following port-names, as it said to do on the install
>> page:
>>    python26
>>    py26-gtk
>>    py26-simplejson
>>    py26-xdg
>> Then I downloaded and unarchived the source for zim0.55, navigated to
>> the folder, and typed "./test.py".  Unfortunately, I got the following
>> error:
>> Traceback (most recent call last):
>>  File "./test.py", line 239, in <module>
>>    main()
>>  File "./test.py", line 88, in main
>>    suite = tests.load_tests(loader, None, None)
>>  File "/Users/rcorty/Desktop/zim-0.55/tests/__init__.py", line 80, in
>> load_tests
>>    test = loader.loadTestsFromName(name)
>>  File
>> "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/unittest/loader.py",
>> line 100, in loadTestsFromName
>>    parent, obj = obj, getattr(obj, part)
>> AttributeError: 'module' object has no attribute 'utils'
> For some reason zim can not find the modules in the local folder. Does
> "tests/utils.py" exist in your folder ?
> If so, you might want to set "export PYTHONPATH=." to force looking in the
> local folder.

I typed this while pwd = /path/to/zim-0.55

Was that what you intended?

After doing so, I typed "./test.py" and got the same error (the one
terminating in "AttributeError: 'module' object has no attribute

I definitely have python 2.6 and 2.7 installed on this computer, since
2.7 comes with Mac OS 10.7 and I used macports to install 2.6.  I
think the problem is in getting zim to realize where they are (or
maybe to use the appropriate one, namely 2.6)

>> I figured I'd just give the install a try so I typed "./setup.py
>> install", and got the following error:
> Try instead to type "python ./zim.py", this should run zim directly from
> source instead of installing first.
> (Make sure to run in an X context, e.g. xterm)

I did so and got the following error:

ERROR: Could not find python module files in path:
list of paths....
....long list of paths....
Try setting PYTHONPATH

So I browsed around my computer looking for where python actually is
and I found it in "Applications/MacPorts/" so I tried setting
PYTHONPATH="/Applications/MacPorts" as well as
"Applications/MacPorts/Python\ 2.6", but got the same error each time.

> Hope this helps, otherwise I hope some other Mac users here have a better
> suggestion.
> Regards,
> Jaap

Follow ups