← Back to team overview

zim-wiki team mailing list archive

Re: Zim version 0.59 released


Has version control been tested on Windows? I have Git so just tried it out...

It wasn't obvious from Configure whether I needed to do anything more but eventually I found the "More info" docs. So then I tried "File > Save Version?" This said version control was not yet enabled, so I confirmed I wanted it and this greated a .git repository but the Zim GUI froze and never came back.

Now Zim won't start up and (as before on Windows) Zim -D is not generating a log.

At this point I noticed there is a new version of Git for Windows so ran the install to bring it up to v1.18 (git-scm.com). The installer noticed Git.exe was running and closed it, at which point the Zim GUI woke up and showed this error dialog:

   Failed to run application: git
   git "commit" "-a" "-m" "Automaticallyse saved version from zim"
   returned non-zero exit status -1073741510

Note that despite this error a ".git" repository was present before Zim unfroze, but has disappeared now but this may be because I disabled sync of .git in Dropbox? That would explain absense of ".zim" here also.

It could be that Dropbox is the culprit here. Can you stop sync without Dropbox doing this!!!? Should I just let it sync ".git" (which I don't like to do?!).

Zim 0.58 / Windows 7



On 25/01/2013 09:04, Jaap Karssenberg wrote:
On Fri, Jan 25, 2013 at 10:02 AM, jayseye<greinze@xxxxxxxxx>  wrote:
Since Bazaar is already used for development, would that work about as
well as git, et. al, for this purpose as well?
Sure, actually that was the first one supported by zim. Others have
been added now.

-- Jaap

Mailing list:https://launchpad.net/~zim-wiki
Post to     :zim-wiki@xxxxxxxxxxxxxxxxxxx
Unsubscribe :https://launchpad.net/~zim-wiki
More help   :https://help.launchpad.net/ListHelp