← Back to team overview

zim-wiki team mailing list archive

Re: Using start AND due date


Trying 0.68-rc 1 doesn't solve the problem of my disappearing tasks after index from the terminal.

Some additional sleuthing indicates running index from the terminal is a likely culprit.

1. When I run `Update Index` from within zim it takes 5-6 seconds.
2. When I run zim --index on the command line, it completes in less than a second, so perhaps it fails and deletes my tasks in the index?

python2.7 zim.py --index  ~/joseph/plan/zim/notebook.zim

Should I be able to run the following with debug too? I get an error:

╰─➤  time python2.7 zim.py --debug --index  ~/joseph/plan/zim/notebook.zim
/usr/local/Cellar/python/2.7.14_2/Frameworks/Python.framework/Versions/2.7/Resources/Python.app/Contents/MacOS/Python: can't open file 'zim.py': [Errno 2] No such file or directory
python2.7 zim.py --debug --index ~/joseph/plan/zim/notebook.zim  0.01s user 0.01s system 78% cpu 0.024 total

BTW I also get a warning messages from GTK when running:

2018-02-03 15:20:36.774 Python[72901:4385493] *** WARNING: Method userSpaceScaleFactor in class NSView is deprecated on 10.7 and later. It should not be used in new applications. Use convertRectToBacking: instead.

Follow ups