← Back to team overview

brewtarget-devs team mailing list archive

Re: Windows problems


This bug is infuriating. When the backup database deletion code first went
in, it didn't work at all on Windows. I couldn't get the Qt file deletion
function to work, and just punted and used a Windows API call. This should
be the prime suspect. I'll investigate next week after the holidays.

On Thu, Dec 18, 2014 at 7:49 AM, mik firestone <mikfire@xxxxxxxxx> wrote:

> I don't know if anybody else is tracking this, but we seem to be having a
> problem deleting the temp db on Windows. Once it is created, it never gets
> deleted and we are always prompting to restore or rollback.
> I've tested this myself and can reproduce it, but only when I install
> brewtarget. If I run brewtarget from my build directory, for example, I
> never see the problem. I have tried installing brewtarget somewhere other
> the c:\program files and a few other variants. None of that seems to make a
> difference.
> My problem is that I can't build a release on Windows. I don't have the
> necessary environments. Can somebody who can build Windows releases take a
> look into this and see what's going on?
> Thanks,
> Mik
> --
> In a world of ninja v. pirate, I pilot a Gundam
> --
> Mailing list: https://launchpad.net/~brewtarget-devs
> Post to     : brewtarget-devs@xxxxxxxxxxxxxxxxxxx
> Unsubscribe : https://launchpad.net/~brewtarget-devs
> More help   : https://help.launchpad.net/ListHelp

Dr. Philip G. Lee

Follow ups