hipl-core team mailing list archive
Mailing list archive
Re: [Branch ~hipl-core/hipl/trunk] Rev 4919: Don't unneccesarily repeat function name in doxygen comments.
On Sun, Aug 29, 2010 at 04:27:25PM +0000, noreply@xxxxxxxxxxxxx wrote:
> Don't unneccesarily repeat function name in doxygen comments.
> As requested by Miika:
> Subject: Re: [Hipl-core] [Branch ~hipl-core/hipl/trunk] Rev 4916: Comment typo.
> Date: Thu, 26 Aug 2010 10:29:00 +0300
> From: Miika Komu <mkomu@xxxxxxxxx>
> To: hipl-core@xxxxxxxxxxxxxxxxxxx
> On 08/25/2010 07:50 PM, noreply@xxxxxxxxxxxxx wrote:
> I would actually suggest to remove the unnecessary function names from
> all doxygen comments. It looks silly in doxygen and has really no
> purpose . Also, forgetting to update the duplicate name does not cause
> any doxygen warning whatsoever.
While I'm all for verbose commit messages, this is IMO taking it
a bit too far.
> === modified file 'hipd/close.c'
> --- hipd/close.c 2010-08-19 09:32:20 +0000
> +++ hipd/close.c 2010-08-25 16:48:22 +0000
> @@ -347,7 +347,7 @@
> - * hip_close_create_response
> + * hip_close_send_response
> * Send a before generated CLOSE_ACK packet.
This is related, how?
> --- hipd/cert.c 2010-08-20 14:34:13 +0000
> +++ hipd/cert.c 2010-08-29 16:24:14 +0000
> @@ -63,8 +63,8 @@
> - * hip_cert_spki_sign - Function that signs the cert sequence and
> - * creates the public key sequence and the signature sequence
> + * Function that signs the cert sequence and creates the public key
> + * sequence and the signature sequence
Sentence that criticizes silly and redundant descriptions within
I will next tell you that it's silly and redundant to tell that you
will tell something instead of just telling it directly.
Anyway, this just crossed my mind, it's of course not directly related
to this commit.