← Back to team overview

kernel-packages team mailing list archive

[Bug 1440446] Re: Keyboard does not respond/scrambled video



I have some more information. As stated in the initial bug report, the latest kernel (3.13.0-48-generic) with KMS enabled gets me to the password prompt for decrypting my root, and the graphics appear to be ok, but the keyboard/mouse do not respond.
On a hunch, I rebooted with this kernel, disconnecting the keyboard until after the password prompt. Upon reconnection,
I am able to use the keyboard, and the root successfully decrypts, but again the boot stalls before getting
to the login screen. In this case, however, I am able to ssh into a shell and get access to more detailed information which may help with diagnosing the failure of KMS in relation to the radeon driver. I attach Xorg.0.log and the output of dmesg.

** Attachment added: "Xorg.0.log and dmesg"

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Keyboard does not respond/scrambled video

Status in linux package in Ubuntu:

Bug description:
  Description:    Ubuntu 14.04.2 LTS
  Release:        14.04
  Kernel 3.13.0-48-generic

  I expected to be apple to boot to the password prompt for my encrypted root (and beyond) with correct graphics.
  Instead I found that my keyboard was not recognised after grub, so I am not able to decrypt my root or login 

  More detailed explanation:

  I have Ubuntu installed on my 17'' core-duo intel imac, with an encrypted root partition.
  Version 12.04 with kernel 3.5.0-17-generic worked ok, but I updated to the LTS version 14.04.
  The system now freezes before asking for my encryption password when booting (I am using EFI with grub2)
  with my old kernel (3.5.0-17-generic) and with no args on the kernel command line. If I put nomodeset the boot
  progresses to the encryption password and I can successfully login, however the video is completely scrambled (I literally cannot
  make out anything). Having tried many ways to fix the video, I tried the latest kernel (3.13.0-48-generic). In this case
  the boot gets to the password and the graphics appear to be ok, but the keyboard/mouse do not respond. Again I tried many fixes, unsuccesfully. I installed the extras so as to have usbhid, mac_hid etc, and found that the behaviour now reverted precisely to that outlined above for 3.5.0-17-generic; that is scrambled graphics but successful login (with nomodeset), and freezing before
  reaching the password prompt (without nomodeset).
  I tried manually adding only the hid modules to my initrd.img-3.13.0-48-generic built prior to install of extra, but found graphics again ok but still no keyboard !

  This report was made via a ssh session after booting with the
  scrambled video.

  ProblemType: Bug
  DistroRelease: Ubuntu 14.04
  Package: linux-image-3.13.0-48-generic 3.13.0-48.80
  ProcVersionSignature: Ubuntu 3.13.0-48.80-generic 3.13.11-ckt16
  Uname: Linux 3.13.0-48-generic i686
  ApportVersion: 2.14.1-0ubuntu3.8
  Architecture: i386
   /dev/snd/controlC0:  lightdm    1678 F.... pulseaudio
                        admin      2808 F.... pulseaudio
  Date: Sun Apr  5 10:33:58 2015
  HibernationDevice: RESUME=UUID=b24198c5-2cbc-45f2-8535-71569a8d69fa
  InstallationDate: Installed on 2013-07-28 (616 days ago)
  InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release i386 (20121017.2)
   lo        no wireless extensions.
   eth2      no wireless extensions.
  MachineType: Apple Computer, Inc. iMac4,1
   PATH=(custom, no user)
  ProcFB: 0 EFI VGA
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.13.0-48-generic root=/dev/mapper/ubuntu-root nomodeset loglevel=7
   Error: command ['pacmd', 'list'] failed with exit code 1: Home directory not accessible: Permission denied
   No PulseAudio daemon running, or not running as session daemon.
   linux-restricted-modules-3.13.0-48-generic N/A
   linux-backports-modules-3.13.0-48-generic  N/A
   linux-firmware                             1.127.11
   0: hci0: Bluetooth
   	Soft blocked: no
   	Hard blocked: no
  SourcePackage: linux
  UpgradeStatus: Upgraded to trusty on 2015-03-16 (19 days ago)
  dmi.bios.date: 10/12/06
  dmi.bios.vendor: Apple Computer, Inc.
  dmi.bios.version: IM41.88Z.0055.B08.0610121350
  dmi.board.asset.tag: Base Board Asset Tag
  dmi.board.name: Mac-F42786C8
  dmi.board.vendor: Apple Computer, Inc.
  dmi.board.version: PVT
  dmi.chassis.asset.tag: Asset Tag
  dmi.chassis.type: 13
  dmi.chassis.vendor: Apple Computer, Inc.
  dmi.chassis.version: Mac-F42786C8
  dmi.modalias: dmi:bvnAppleComputer,Inc.:bvrIM41.88Z.0055.B08.0610121350:bd10/12/06:svnAppleComputer,Inc.:pniMac4,1:pvr1.0:rvnAppleComputer,Inc.:rnMac-F42786C8:rvrPVT:cvnAppleComputer,Inc.:ct13:cvrMac-F42786C8:
  dmi.product.name: iMac4,1
  dmi.product.version: 1.0
  dmi.sys.vendor: Apple Computer, Inc.

To manage notifications about this bug go to: