← Back to team overview

kicad-developers team mailing list archive

Re: Building on Mac OSX 10.6.2 fails with wxMac-2.8.10


I would thank Marco to contact me by chat, so we can further test Mac OS X as platform to do official releases parallel with KiCad.

--- In kicad-devel@xxxxxxxxxxxxxxx, "emmedics4" <marco.serantoni@...> wrote:
> --- In kicad-devel@xxxxxxxxxxxxxxx, "wafeliron" <wafeliron@> wrote:
> > I checked latest sources out of SVN and still i can't figure out why i cant compile on OSX. I build wxMac-2.8.10 myself.
> > And I run Snow Leopard 10.6.2 on a macbook 5,2.
> > The check macro can be fixed with a small hack that i committed in Documents/compiling/boos_mac_osx_notes.txt
> > This works, but then I get a scope error that the function is not defined. I know you compile and build often for OSX.
> > Maybe Marco Serantoni has some tips and tricks. Also I don't like the depreciated warning, is this fixed in wxMac-2.9 SVN? If we can get it compiling and working I hope the OSX users can bundle
> > strength to make next release also official for OSX.
> Jerry,
> Using Snow Leopard you should dump wx-2.8,SnowLeopard doesn't allow you compile some Carbon calls deprecated by years and still used in 2.8.xx.
> This is the reason why i'm working principally on 2.9svn, and i'm filing bug reports to wxWin developers.
> The last one was this : http://trac.wxwidgets.org/ticket/11581 and was resolved recently as you can seen.
> I'm compiling wxWidgets with those settings:
> ./configure --enable-unicode=yes --enable-shared=no --enable-monolithic --with-opengl --enable-universal_binary --enable-aui --enable-debug --with-osx_cocoa --with-macosx-sdk=/Developer/SDKs/MacOSX10.5.sdk/
> I've also hacked the configure file to include all three the directives -arch for the needed platforms, sadly build system of wxWidgets is changing too quickly for releasing something written (i've tried with enviroment variables some months ago but was a faliure).
> Regarding Kicad the only things i've changed are the Variables:
> CMAKE_OSX_ARCHITECTURE = x86_64 -arch i386 -arch ppc -isysroot /Developer/SDKs/MacOSX10.5.sdk/ -mmacosx-version-min=10.5
> CMAKE_OSX_SYSROOT = /Developer/SDKs/MacOSX10.5.sdk
> The last one if i recall well is your trick to bypass the problems with "check" macro.
> Regarding the code in my last build was plain vanilla except the workaround (now almost unusefully) for resolved bug #11581 and the fix on kicad's GetChars() already committed by jean-pierre the 29 December.
> I'm confident that we are (al)ready for a not too badly Official release soon.
> If you feel i can help you in some way and want to cut times i'm also avaiable on yahoo chat often.
> --
> Marco