kicad-developers team mailing list archive
Mailing list archive
File naming policy.
I'm getting ready to do some refactoring of the library object code and I would
like to split the component library object file classes_body_items.cpp into
individual files per object. This file is currently over 2000 lines long and
has become unwieldy to edit. One thing I'm not particularly thrill about is
the current class_foo.cpp file naming scheme. It seems redundant to me prefix
class_ to C++ source files. Would any one object to them not be prefixed with
class_. In other words lib_arc.cpp, lib_circle.cpp, lib_rectangle.cpp, etc. I
would like to get this complete before we create the branch for the new library
stuff to prevent merge issues. There is no formal policy on this so I thought
I would ask before I plow ahead.