← Back to team overview

kicad-developers team mailing list archive

Re: [PATCH] Refactor LAYER_ID to be the one and only layer definition


On Tue, Mar 14, 2017 at 07:05:59PM -0400, Wayne Stambaugh wrote:
> Hey Jon,
> This is better than the giant enum concept and I'm willing to accept
> this.  It still lacks the type safety of the enum inheritance solution.

Bad memories with layers enums :D funny thing when I proposed the layer_id solution other people told me 'integers are easier to use'. Oh well

By the way, with 'enum inheritance' are you referring to class enums? Never used them but they seem a fine concept

Lorenzo Marcantonio

Attachment: signature.asc
Description: PGP signature